POJ:2367 Genealogical tree(普通简单版拓扑排序)


Genealogical tree
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4629 Accepted: 3074 Special Judge

Description

The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural. 
And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there's nothing to tell about his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal. 
Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.

Input

The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member's children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it is empty) ends with 0.

Output

The standard output should contain in its only line a sequence of speakers' numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.

Sample Input

5
0
4 5 1 0
1 0
5 3 0
3 0

Sample Output

2 4 5 3 1

Source

Ural State University Internal Contest October'2000 Junior Session题目大意:有n个人,接下来n行,每一行以0结尾,每行的意思:如第二行,就是编号为2的人在4 5 1这三个人前面,求出符合要求的序列。解题思路:这道题数量少,用普通二维数组来拓扑排序就可以解决问题。代码如下:
#include <cstdio>
#include <cstring>
int map[110][110];
int ans[110];
int in[110];
int n;
void tuopu()
{
int num=0;
for(int j=1;j<=n;j++)//每次找到一个入度为0的节点 ,一共n个,所以循环n次
{
int flag=-1;
for(int i=1;i<=n;i++)//每次找到一个入度为0的节点
{
if(in[i]==0)
{
flag=i;
break;
}
}
in[flag]=-1;
ans[num++]=flag;//每处理一个节点,就加入答案数组
for(int i=1;i<=n;i++)
{
if(map[flag][i]==1)
{
in[i]--;
}
}
}
for(int i=0;i<num-1;i++)
{
printf("%d ",ans[i]);
}
printf("%d\n",ans[num-1]);
}
int main()
{
while(scanf("%d",&n)!=EOF)
{
memset(map,0,sizeof(map));
memset(in,0,sizeof(in));
for(int i=1;i<=n;i++)
{
int j;
while(scanf("%d",&j)!=EOF)
{
if(j==0)
break;
if(map[i][j]==0)
{
map[i][j]=1;
in[j]++;
}
}
}
tuopu();
}
return 0;
}


智能推荐

注意!

本站转载的文章为个人学习借鉴使用,本站对版权不负任何法律责任。如果侵犯了您的隐私权益,请联系我们删除。



 
© 2014-2019 ITdaan.com 粤ICP备14056181号  

赞助商广告